How do I get Holidays working with Compass hardware
Author: Lee ArhelgerCreated: 03-04-2013 07:52 PMLast Updated: 08-02-2021 09:55 PM

Products to which this article applies

  • Intelli-Site
  • MASC

Issue

How do holidays work?

Cause

Either door opened on a holiday when it shouldn't have or a door was locked on a day it should have been open.

Resolution

Holidays are handled differently depending on the access control hardware you have.

If you have version 3.9.47, 3.9.48, or version 3.9.49, please upgrade to version 3.9.50 or better[LAT1].  A bug concerning Holidays existed in these versions and was fixed in 3.9.50.

General Considerations

In some cases, it might be better to use First In instead of holidays. The advantage is that if there is a snow day or a holiday the doors do not unlock on schedule unless someone shows up. Set a First In Time Code and if a card is presented during that time the doors will unlock at the scheduled time. General recommendation is the First In Time Code runs from 15 minutes to a half-hour before the scheduled opening until one minute after the scheduled opening.

This article applies to Compass hardware

Holiday Usage for Card Access Rights

For Compass panels, there is a default holiday group called ‘No Holidays’.  You can find it under the Access Control -> Compass Panel ->Holidays node

It contains no dates, nor can any dates be added to it, nor can the name be changed, nor should it be moved.  As soon as a day is included in any other Holiday group, it is treated as an exception to the normal TimeCode schedule by the panel. When a Time Code uses the Holiday group ‘No Holidays’, Access Levels that use this Time Code will deny access on ANY holiday no matter in which Holiday group the holiday is defined. It may seem counterintuitive that the No Holidays group is empty, it means the door will not unlock on any holiday. Remember that any holiday in any group applies to the No Holidays group. 

Time Codes can be found under the Compass RTU node.  When a Compass RTU is added, a default time code is added as well.  This time code is the ‘Always’ time code.  By default, this time code includes the ‘No Holidays’ group. The ‘Always’ time code defines 24/7 access for any day that is not defined as a holiday.  And since by default no holidays have been defined, this is 365 days a year. However once a holiday is added this is no longer true.

The most common procedure is to create a Holiday Group called ‘All Holidays’.  Add the dates for the company holidays, (e.g. Jan. 1, July 4th, etc.).  Please note that though the calendar picker is a multi-year schedule, the Compass panel does not handle multiple years.  It only knows one year at a time. Save when all the desired dates have been added.

As a side note, not every year has the same holidays.  Memorial Day is a different day every year, and for some years, July 5th is included as a holiday and not others.  The dates for the holidays must be updated every year so the actual holidays for the company are observed.  If not, the Compass panels will use the same dates from last year until they are updated

You may create any number of Holiday groups depending on your needs.  We strongly suggest that a group called ‘All Holidays’ be created and then the ‘Always’ Time Code modified to use this Holiday group.  That way someone always has access to the facility.  Make sure you modify the Time Code on every Compass panel. Even if you are not currently entering holidays we suggest that you create an All Holidays group and change the Always access level to use that on each panel. Then if holidays are ever used people with Always access will not be locked out. This will be the case for most facilities.

Holidays are treated as the exception to the rule. If the normal schedule is doors open M-F business hours and No Holidays is selected then when a holiday that is in the All Holidays group happens to occur the doors will remain locked.

Holiday Usage for Device Control (Lock/Unlock, Enable/Disable)

When defining Holidays and Holiday groups, it is important to consider their impact on schedules defined for device control. Typically a facility’s doors that would normally unlock on a daily schedule should remain locked on a holiday. This can be accomplished by defining the TimeCode schedule to include the ‘No Holidays’ group. This applies to disable and delay schedules defined for inputs as well.

Examples of holiday usage:

TimecodeStart TimeEnd timeDaysHoliday group
Timecode 100:0023:59S,M,T,W,T,F,SNo Holidays
Timecode 200:0023:59S,M,T,W,T,F,SAll Holidays
Timecode 308:0017:00S,M,T,W,T,F,SNo Holidays
Timecode 408:0017:00S,M,T,W,T,F,SAll Holidays

Timecodes 1 and 2 in the above example are defined as access schedules. Timecode 1 defines a 24/7 schedule, but will not allow access on any defined holidays. Timecode 2 also defines a 24/7 schedule but will allow access on holidays included in the ‘All Holidays’ group.

Timecodes 3 and 4 are applied to a door unlock schedule. Timecode 3 defines an 8 am-5 pm Monday–Friday schedule and will not unlock the doors on any defined holidays, whereas Timecode 4 defines a similar schedule, but will allow the doors to unlock on holidays included in the ‘All Holidays Group’.

Multi Groups

If the facility has different panels with different holiday needs, such as a church-school combination, you may need multiple groups. In this case, the holiday groups would be, No Holidays, All Holidays, Non-School Holidays, and Non-Church Holidays. So if we have an observed holiday schedule like this:

HolidayChurchSchool
New YearsXX
Good FridayX
July 4thXX

You most likely will need three holiday groups; No Holidays (empty), All Holidays (all three), and Non-Church Holidays (contains Good Friday). It may seem counterintuitive that the No Holidays group is empty, it means the door will not unlock on any holiday. Remember that any holiday in any group applies to the No Holidays group. So a school door with an ‘M-F No Holiday’ schedule will not open on any holiday no matter what group it is in.

In our example, the school is closed on Good Friday but the church is not. So in order to have the doors unlock for the church, the schedule adds Non-Church Holidays to the door schedule. (You would add July 4th as well if it happened to fall on a Sunday.) Adding a holiday to the schedule only works if that day of the week is already a scheduled open day like this example where Non-Church Holidays contains Good Friday;

We need to add Non-Church Holidays to the schedule because Good Friday is a holiday for the school but this is the church where the doors need to unlock. Think of it as another check box, M is checked so the doors will open on Mondays. Non-Church Holidays are "checked" so the doors will open on the contained within Good Friday. If Friday was not a normally open day it would not open on Good Friday. Putting Non-Church Holidays in the schedule allows this Time Code to be used for the church to have the door unlock on Good Friday.

Cardmembers

If you want to restrict access to some employees on only some holidays then you need more groups. Say for example the church secretary does have access on January 1st but is not allowed in the building on July 4th. However, if July 4th falls on a Sunday then they would have access and in this case, July 4th would need to be in the Non-Church Holidays group. In this case, we will assume that July 4th is on a Wednesday and normal card access is M-F. Then you would need a holiday group ‘Employee Allowed Holidays’ and put January 1st in it. Then create a Time Code with that holiday group so that you can create an Access Level for employees

Putting holidays into effect:

After you are done with holiday creation be sure to do a complete download to all panels.

Products to which this article applies

  • Intelli-Site
  • MASC